Jump to content
Sign in to follow this  
lm81

Napisy do plików .mkv - poradnik

Recommended Posts

no ale pytanie-problem jest zgoła inne. SubEdit działa poprawnie . A przynajmniej daje dobry efekt po zmianie fps napisów i konwersji z mikroDVD do srt. Nie rozumem tylko dlaczego mediainfo podaje błednie (a może nie) fps filmu i napisy z takim samym fps po wmuksowaniu nie grają z filmem.

Share this post


Link to post
Share on other sites

Witam problem mam. bo wmuxowanie napislo wajmuje mi duzo czasu (chodzi o czas zapisywania pliku(mam sataII)) wiec wolę wklejac napisy jednak vobsub nie odpala mi sie przy plikach mkv:/ i nie moge wczytac napisów macie jakis inny podobny program ktory wkleja napisy automatycznie (film.mkv,film.txt). Uzywam do filmów tylko Media center bo mam multimedialnie w saloonie. Prosze o pomoc.

Share this post


Link to post
Share on other sites

Witam. Potrzebuje pomocy i to nie małej. Mam LG BD370 który zcyta mkv. I takie też pliki posiadam. Ale chciałbym sam sobie dopasowywać napisy. I tu pojawia sie problem . Mam np Australie w jednym pliku mkv i do tego napisy do 2-płytowej wersji w txt. Czy mógłby mi ktoś pomóc bo mam program Subtitle Workshop ale nie potrafie sie z nim dogadać. Chciałbym połączyc ten plik w jeden i dopasować do tego filmu. Prosze o porade jak to zrobic albo na PM albu tu an forum. Z góry dziekuję za cierpliowość

Share this post


Link to post
Share on other sites

SW , Ctrl + J , dodaj pierwsze napisy, potem drugie , fps ustaw na 23,976, zaznacz przelicz wartości czasów, Połącz!

Można dla pewności wcześniej przekonwertować napisy txt na srt i dopiero te ostatnie łączyć. Po połączeniu może być potrzebna mała korekta przesunięcia w miejscu łączenia plików. Zaznacz drugą połączoną połowę filmu , Ctrl + D , popraw przesunięcie.

Share this post


Link to post
Share on other sites

Spróbuj w ustawieniach ścieżki ustawić:

Default track flag: yes

Forced track flag: yes

Jeżeli masz kilka ścieżek z napisami, to przyciskiem UP

przenieś ją ponad wszystkie inne napisy.

Powinno pomóc.

Pozdrawiam,

Paweł

Share this post


Link to post
Share on other sites

Do czego służy opcja "link files" w zakładce Splitting?

Powinna być zaznaczona czy odznaczona jeśli dzielę jeden plik 7,94GB na dwie części, aby weszły na płytę DVD5?

Share this post


Link to post
Share on other sites

Ja nigdy nie zaznaczam opcji link files i zawsze dobrze dzieli. W zasadzie nie wiem do czego ona służy.

@Diablo73

Może pokombinuj z kodowaniem napisów w subtitle workshop albo w mkvmerge wejdź w format specyfic options, potem "Charset" i potestuj ustawienia.

Edited by lm81

Share this post


Link to post
Share on other sites

Po pierwsze: wielkie dzięki za ten opis. Już multum filmów "obsłużyłem" w ten sposób - świetna sprawa.

Ale niestety nie jest tak różowo, jak mogłoby być.

Otóż po wmuxowaniu napisów i podzieleniu mkvmerge na dwa pliki, KMPlayer przy zaznaczonej opcji "odtwarzanie bez przerw" nie wyświetla napisów w drugim pliku.

Nie wiem czy się orientujecie o co chodzi z tą opcją, mam nadzieję że tak. Chodzi o to, że KMPlayer traktuje dwie części filmu jako jeden plik - mamy jeden suwak czasu na cały film, nie ma szarpnięcia/doładowania przy przechodzeniu między plikami - wszystko płynnie. Tylko te napisy nie ryrają :/

Share this post


Link to post
Share on other sites

Wyciągnięte polskie napisy z pliku mkv do srt (MKVExtractGUI) nie mają polskich znaków - same krzaczki.

MKVMergeGUI w opisie ścieżki mówi, że format jest UTF8.

Czy można coś na to poradzić? Czy po prostu są już źle od początku zapisane i nic się z tym nie zrobi?

pozdrawiam

Share this post


Link to post
Share on other sites
Wyciągnięte polskie napisy z pliku mkv do srt (MKVExtractGUI) nie mają polskich znaków - same krzaczki.

MKVMergeGUI w opisie ścieżki mówi, że format jest UTF8.

Czy można coś na to poradzić? Czy po prostu są już źle od początku zapisane i nic się z tym nie zrobi?

pozdrawiam

Idę o zakład że napisy są uwalone, osoba robiąca enkoda zocerowała napisy z BD z błędami lub skorzystała ze słabego gotowca, widziałem już takie ripy nawet najlepszych grup : ESiR, CtrlHD, DON ...

Żadne zmiany kodowania w takim przypadku nie pomogą.

Jak chcesz się pobawić to odpal napisy w notatniku i skorzystaj z funkcji Zamień wszystko (Ctrl + H) dla odpowiednich znaków, lub po prostu skorzystaj z lepszych napisów.

Pozdrawiam

Share this post


Link to post
Share on other sites

Witam

Od niedawna mam tv Samsung LE40 C650. niestety jestem totalnym laikiem jeśli chodzi o filmy, montaż lub inne działania. Czytałem starannie instrukcję, niestety efektu brak.

Opiszę dokładnie co mam i co robię, może ktoś zauważy błąd przez co będzie to działać jak należy.

Posiadam plik *.mkv, ma on 2 strumienie video i audio. Po przerobieniu napisów na ssa i ass, staram się połączyć to wszystko w jedność. Zgodnie z instrukcją, przesuwam na 3 pozycję w kolejności strumieni, zmieniam język i ustawiam yes. Następnie klikam przycisk powodujący rozpoczęcie operacji.

Po zabiegu efekt nie jest taki jak się spodziewałem. Po otworzeniu filmu w Media Clasic Player, napisów nie widać. Po otworzeniu w VLC Media Player efekt ten sam, chyba że zrobię tak: obraz > napisy > i wybiorę ścieżkę napisów powiedzmy 2, to wtedy się dopiero pojawiają.

Niestety w tv nie mam takich opcji aby tak samo je włączyć.

Co muszę zrobić aby to dobrze połączyć, aby efekt był taki jaki oczekuje, czyli napisy nałożone na film HD?

z góry dziękuję za pomoc

Share this post


Link to post
Share on other sites

Witam

od niedawna zaczolem korzystac z ww programu. Wszystko pieknie chodzilo do czasu reinstala systemu, teraz po reinstalu tez dziala ale niedokonca chodzi mianowicie o to ze gdy przerabiam napisy z txt do srt a pozniej wmuxuje do pliku mkv na kompie wszystko dzial cacy lecz gdy przenosze juz filma na odzielny dysk i chce sobie go odtworzyc za pomoca WD HD bez uzycia kompa jest klapa nic sie niedzieje czarny obraz inne filmy chodza cacy[te przed reinstalem] jaka moze byc tego przyczyna?

Share this post


Link to post
Share on other sites

wiem że trochę czasu już minęło ale może ktoś wie: jak zmienić kolor napisów w dvdfab.

po wmuxowaniu w plik mkv napisy są żółte. a w opcjach programu nie ma zmiany na białe. wie ktoś jak to zrobić?

Share this post


Link to post
Share on other sites

telemaniak - przy napisach powinieneś mieć jakies FFF coś tam oznaczające kolor albo w ustawieniach wyświetlania napisów szukaj opcji zmiany koloru

morrtis - źle muxujesz? - sprawdx ustawienia

nodions - co ustawiasz na yes i gdzie?na yes ustawiasz główna podstawową ścieżkę video, audio oraz napisów - może dałes dwie z napisami na default - yes i problem powstał

Share this post


Link to post
Share on other sites
wiem że trochę czasu już minęło ale może ktoś wie: jak zmienić kolor napisów w dvdfab.

po wmuxowaniu w plik mkv napisy są żółte. a w opcjach programu nie ma zmiany na białe. wie ktoś jak to zrobić?

W jakim formacie masz ten napisy ?

Napisy w formacie SSA mają możliwość wyboru wielkości/koloru/obwódki czcionki :

Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, TertiaryColour, BackColour, Bold, Italic, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, AlphaLevel, Encoding

Style: Default,Helvetica Narrow,26,16777215,16777215,0,0,0,0,1,1,1,2,40,40,20,0,238

Widać to wsio po ręcznej edycji pliku napisów np w notatniku.

Edited by gienas

Share this post


Link to post
Share on other sites

napisy sa jako .srt

ale jak wrzucisz je do dvdfab to sa żółte na ekranie...... jak dodasz poprzez np. mkv2vob to sa białe, ewidentnie program zmienia kolor na żółty. a ja wolałbym białe

Share this post


Link to post
Share on other sites

Witam.

Niedawno zacząłem przygodę z HD. Skorzystałem z poradnika zamieszczonego w temacie i wszystko jest w najlepszym porządeczku tyle, że przy odtwarzaniu na kompie. Po dodaniu napisów film nie odtwarza się na stacjonarnym BD /LG 560/. Próbowałem też ze ścieżką audio. Po dodaniu VLC widzi i odtwarza bez problemu, odtwarzacz BD nie otwiera pliku. Widziałem, że kolega kilka tematów wyżej miał podobny problem, nikt jednak nie odpowiedział. Może do tej pory ktoś też walczył z podobnym babolem. Pozdrawiam.

Share this post


Link to post
Share on other sites

Witam, ja mam podobny problem.

Po wmuxowaniu napisów w film na kompie jest wszystko elegancko ale blu-ray sony bdp-s370 tych napisów już nie widzi.

Jak udostępniam film przez wild media server film się odtwarza ale nie czyta napisów a gdy udostępniam ten sam film przez sieciowy dysk Iomega w ogóle filmu nie odtwarza.

Macie pomysł co może się dziać nie tak?

Wmuxowuje napisy wg instrukcji z 1 strony tematu potwierdzonej przez inne źródła w necie.

Share this post


Link to post
Share on other sites

Mam problem z napisami, dokładniej z polskimi znakami.

Otwierając plik srt w notatniku widoczne są polskie litery natomiast xbmc nie odczytuje ich i robi kaszanę z polskimi znakami - będę bardzo wdzięczny za pomoc.

pozdrawiam

Edited by kil

Share this post


Link to post
Share on other sites

Mam problem z napisami, dokładniej z polskimi znakami.

Otwierając plik srt w notatniku widoczne są polskie litery natomiast xbmc nie odczytuje ich i robi kaszanę z polskimi znakami - będę bardzo wdzięczny za pomoc.

pozdrawiam

Czy masz tak Ustawienia>>>Napisy>>>Zestaw znaków>Central Europe ?

Share this post


Link to post
Share on other sites

witajcie mam taki problem.

Mam plik mkv.

W mkvmerge GUI dodaje do niego napisy

i teraz aby otworzyc to na tv/ps3 musze miec inny format.

jak to przerobic na taki format aby dalo sie ogladac?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...